Forum CiviCRM Polska

Hosting dla CiviCRM

Autor Wątek: Hosting dla CiviCRM  (Przeczytany 6298 razy)

njakub

  • Nowicjusz/ka
  • *
  • Wiadomości: 21
  • Karma: +0/-0
  • Imię: Jakub
  • Nazwisko: N.
Hosting dla CiviCRM
« dnia: 19.03.2014, 22:38 »
Na stronach CiviCRM nie ma żadnych informacji, by w Polsce działały hostingi w jakiś sposób współpracujące z tym oprogramowaniem. Ale może macie jakieś doświadczenia z polskimi dostawcami, gdzie CiviCRM działa bezproblemowo?

A jeśli nie - to jakie warunki musi spełniać oferta, żeby można było myśleć o jej wyborze?

michau

  • Administrator/ka
  • Bywam tu często
  • *****
  • Wiadomości: 206
  • Karma: +2/-0
  • Imię: Michał
  • Nazwisko: Mach
Odp: Hosting dla CiviCRM
« Odpowiedź #1 dnia: 20.03.2014, 13:07 »
Jeżeli chodzi o wymagania, to na większe instalacje najlepiej mieć dedykowany serwer, ale bazy kilkanaście-kilkadziesiąt tysięcy rekordów standardowy hosting wystarcza. Wymagania w sumie takie jak: http://wiki.civicrm.org:8090/confluence/display/CRMDOC/Installation+and+Upgrades Czasem pojawiają się jakieś specyficzne ograniczenia, takie jak safe_mode w PHP, ale w większości przypadków daje się je obejść. Na pewno największym ograniczeniem jest możliwość korzystania z TRIGGERów w MySQLu, poczynając od wersji 4.3.

Moje doświadczenia z hostingiem:
home.pl - problemy w trakcie instalacji Drupala i CiviCRMa, ale wszystko do rozwiązania i nawet działa w wersji LTS 4.2.* (w razie potrzeby służę szczegółami), nie ma TRIGGERów
nazwa.pl - instalacja stosunkowo bezproblemowa, działa, nie testowałem u nich TRIGGERów
linuxpl.com - w sumie bez problemów, ale nie testowałem u nich TRIGGERów

m

P.S. Można też hostować u nas, ale robimy to tylko dla klientów, którym wdrażamy CiviCRMa (razem z hostingiem robimy na bieżąco aktualizacje).

njakub

  • Nowicjusz/ka
  • *
  • Wiadomości: 21
  • Karma: +0/-0
  • Imię: Jakub
  • Nazwisko: N.
Odp: Hosting dla CiviCRM
« Odpowiedź #2 dnia: 20.03.2014, 19:16 »
Na ten moment nasza baza danych zawiera mniej niż 1000 kontaktów, więc zdecydowanie musi wystarczyć hosting ;)

Czyli największy problem jest z triggerami.

Prawdę mówiąc, jeśli jestem w stanie tego uniknąć, wolałbym pracować na najnowszej wersji. Moja organizacja ma hosting na home.pl (nie moja decyzja ;-) ), ale ze względu na osławione parametry myślę o innym miejscu dla Civi.

Linuxpl.com twierdzi, że działają u nich triggery i że mieli doświadczenie z CiviCRM na ich serwerach. Nie wiem jednak, czego potrzebuję: ile miejsca na serwerze, miesięcznego transferu, wywołań do baz danych, obciążenia serwera itp.

Michale, czy można zapoznać się z Waszą ofertą? Nie mogę jej znaleźć.

michau

  • Administrator/ka
  • Bywam tu często
  • *****
  • Wiadomości: 206
  • Karma: +2/-0
  • Imię: Michał
  • Nazwisko: Mach
Odp: Hosting dla CiviCRM
« Odpowiedź #3 dnia: 21.03.2014, 06:57 »
Z tymi najnowszymi wersjami w CiviCRMie wcale nie jest tak różowo - rozwój jest gwałtowny, dochodzi dużo nowych funkcji, a co za tym idzie zdarzają się błędy regresyjne. :-)

Ja dla klientów, którzy używają home.pl albo innego analogicznego hostingu instaluję wersję 4.2.* - to tak zwana wersja LTS (Long Term Support), do której cały czas pojawiają się poprawki bezpieczeństwa. Najnowsza w tej chwili to 4.2.16. Funkcjonalnie jest niewiele "gorsza" od aktualnej serii 4.4, a jest naprawdę stabilna (tylko poprawki bezpieczeństwa), no i nie wymaga triggerów.

Jeżeli chodzi o naszą ofertę - nie można jej znaleźć, bo jej nigdzie nie ma. :-) Tak jak pisałem, robimy to tylko dla klientów, którym sami wdrażamy CiviCRMa, więc za każdym razem warunki są ustalane oddzielnie.

m

njakub

  • Nowicjusz/ka
  • *
  • Wiadomości: 21
  • Karma: +0/-0
  • Imię: Jakub
  • Nazwisko: N.
Odp: Hosting dla CiviCRM
« Odpowiedź #4 dnia: 22.03.2014, 00:45 »
Nie pytam o ofertę hostingową, tylko w ogóle – jesteśmy na etapie decyzji (że chcemy CRM i będzie to CiviCRM), ale niewykluczone, że będziemy potrzebować pomocy.

Jak to już ktoś napisał, stawianie CiviCRM na home.pl to rozwiązanie krótkoterminowe – będzie dobre, dopóki LTS nie używa triggerów. Potem i tak czekałyby mnie przenosiny. Polecasz LTS również na innych serwerach?

EDIT: znalazłem taką wypowiedź: http://forum.civicrm.org/index.php?topic=31661.msg135648#msg135648
« Ostatnia zmiana: 22.03.2014, 00:54 wysłana przez njakub »

Kalor

  • Nowicjusz/ka
  • *
  • Wiadomości: 20
  • Karma: +2/-0
  • Imię: Karol
  • Nazwisko: Krzyczkowski
Odp: Hosting dla CiviCRM
« Odpowiedź #5 dnia: 22.03.2014, 14:38 »
Co do home.pl, to starsze wersje CiviCVR, krtóre nie wymagaja triggerów śmigaja z wordpressem - nie mamy z tym problemów.

Home oferuje 2 produkty, albo konta typu Hosting (bez triggerów na MySQL), albo serwery dedykowane homecloud - tam teoretycznie powinno wszystko działać. Nie testowałem takiego rozwiązania.

michau

  • Administrator/ka
  • Bywam tu często
  • *****
  • Wiadomości: 206
  • Karma: +2/-0
  • Imię: Michał
  • Nazwisko: Mach
Odp: Hosting dla CiviCRM
« Odpowiedź #6 dnia: 24.03.2014, 11:35 »
Generalnie podstawowym problemem są triggery - i trzymam się zdania, że niskobudżetowy hosting w home.pl z LTSem to nie jest złe rozwiązanie. :-) Ale oczywiście, jeżeli dopiero wszystko się decyduje i jest taka możliwość, to zaczęcie od razu od 4.4 jest bardzo dobrym rozwiązaniem.

Ja ogólnie liczę na to, że home.pl się opamięta i niedługo dadzą wreszcie uprawnienia SUPER dla użytkowników, bo od strony technicznej nie istnieją przeciwskazania, z tego co pamiętam, mają już MySQL 5.5 u siebie.

m

trogloerudyta

  • Nowicjusz/ka
  • *
  • Wiadomości: 11
  • Karma: +0/-0
  • Imię: Janusz
  • Nazwisko: Kaźmierczak
Odp: Hosting dla CiviCRM
« Odpowiedź #7 dnia: 29.07.2015, 12:59 »
Chciałem zainstalować CIVI 4.6.5 przy Joomla na hostingu OVH. Dziś dostałem informację, że triggerów nie ma.

Czy wobec tego:
1. Lepiej przenieść stronę na inny hosting? Jaki da triggery?
2. Zainstalować CIVI w wersji LTS. Czy będzie brakowało jakichś funkcjonalności?
Dzięki za podpowiedź

michau

  • Administrator/ka
  • Bywam tu często
  • *****
  • Wiadomości: 206
  • Karma: +2/-0
  • Imię: Michał
  • Nazwisko: Mach
Odp: Hosting dla CiviCRM
« Odpowiedź #8 dnia: 29.07.2015, 17:32 »
Bez triggerów daleko nie pojedziesz niestety - ostatnią wersją, która według mojej wiedzy działała płynnie bez tej funkcjonalności to chyba 4.2, być może też 4.3. :-(

4.2 parę miesięcy temu był LTSem, teraz już nie jest wspierany i seria 4.4 przejęła bycie LTSem. W sumie próbowałbym od razu z 4.6 - nie instalowaliśmy jeszcze tej wersji na home.pl, ale generalnie nie widzę czemu miałoby się nie udać.

Pozdr,m